Resolved -
Between July 19, 2026, at 23:05 UTC and July 20, 2026, at 03:55 UTC, Actions self-hosted and larger runners were unable to connect to GitHub. During this period, Actions jobs were delayed or failed when trying to acquire a runner. Jobs using standard and Mac hosted runners were not affected. Reconnection traffic from affected runners also increased load on GitHub APIs, resulting in 3-4 seconds of additional average request latency and elevated 5xx error rates.
The incident was caused by a certificate lifecycle management failure in a subset of internal services, resulting in an SSL certificate expiration that disrupted runner connectivity. We restored service by rotating the affected certificate. Recovery began at 02:45 UTC. By 03:55 UTC, queued workflow backlog had been processed and workflow delay rates returned to normal.
To prevent recurrence, we are strengthening certificate renewal automation, adding fallback expiry monitoring and alerting, and improving circuit-breaker protections during runner API disruptions to reduce the risk of cascading impact to other APIs.
Jul 20, 04:44 UTC
Update -
Actions has fully recovered, and we will continue to monitor the platform to ensure stability.
Jul 20, 04:43 UTC
Monitoring -
The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Jul 20, 03:34 UTC
Update -
We’re seeing recovery across all impacted Actions runners. The team is continuing to monitor for global recovery.
Jul 20, 03:27 UTC
Update -
API Requests is operating normally.
Jul 20, 03:03 UTC
Update -
Issues, API Requests, and Pages have recovered. We are continuing to work on restoring GitHub Actions jobs using self-hosted or larger-hosted runners.
Jul 20, 02:43 UTC
Update -
API Requests is experiencing degraded performance. We are continuing to investigate.
Jul 20, 02:23 UTC
Update -
Issues is operating normally.
Jul 20, 02:20 UTC
Update -
Pages is operating normally.
Jul 20, 01:37 UTC
Update -
We continue to work on mitigative efforts to restore Actions workflow runners, and have observed that the extended downtime has started to cause knock-on effects to other services.
A separate incident was opened before we understood they were related. We will continue to post updates on this incident.
Jul 20, 01:11 UTC
Update -
Issues is experiencing degraded performance. We are continuing to investigate.
Jul 20, 00:52 UTC
Update -
Actions and Pages are experiencing degraded performance. We are continuing to investigate.
Jul 20, 00:49 UTC
Update -
Actions is experiencing degraded performance. We are continuing to investigate.
Jul 20, 00:48 UTC
Update -
Actions is experiencing degraded availability. We are continuing to investigate.
Jul 20, 00:20 UTC
Update -
API Requests is experiencing degraded availability. We are continuing to investigate.
Jul 20, 00:07 UTC
Update -
We have identified the cause of failures in GitHub Actions and are working to restore service.
Jul 19, 23:57 UTC
Update -
We are investigating degraded availability for GitHub Actions on github.com and in GHEC DR stamps. New workflows may delay or fail to start, and ongoing runs may fail. We will provide more information as soon as we can.
Jul 19, 23:37 UTC
Investigating -
We are investigating reports of degraded performance for Actions
Jul 19, 23:34 UTC