Resolved -
On March 21st, 2025, between 05:43 UTC and 08:49 UTC, the Actions service experienced degradation, leading to workflow run failures. During the incident, approximately 2.45% of workflow runs failed due to an infrastructure failure. This incident was caused by intermittent failures in communicating with an underlying service provider. We are working to improve our resilience to downtime in this service provider and to reduce the time to mitigate in any future recurrences.
Mar 21, 09:34 UTC
Update -
Actions is operating normally.
Mar 21, 09:34 UTC
Update -
We have made progress understanding the source of these errors and are working on a mitigation.
Mar 21, 09:05 UTC
Update -
We're continuing to investigate elevated errors during GitHub Actions workflow runs. At this stage our monitoring indicates that these errors are impacting no more than 3% of all runs.
Mar 21, 08:20 UTC
Update -
We're continuing to investigate intermittent failures with GitHub Actions workflow runs.
Mar 21, 07:27 UTC
Update -
We're seeing errors reported with a subset of GitHub Actions workflow runs, and are continuing to investigate.
Mar 21, 06:55 UTC
Investigating -
We are investigating reports of degraded performance for Actions
Mar 21, 06:21 UTC