Resolved -
On March 18th, 2025, between 23:20 UTC and March 19th, 2025 00:15 UTC, the Actions service experienced degradation, leading to run start delays. During the incident, about 0.3% of all workflow runs queued during the time failed to start, about 0.67% of all workflow runs were delayed by an average of 10 minutes, and about 0.16% of all workflow runs ultimately ended with an infrastructure failure. This was due to a networking issue with an underlying service provider. At 00:15 UTC the service provider mitigated their issue, and service was restored immediately for Actions. We are working to improve our resilience to downtime in this service provider to reduce the time to mitigate in any future recurrences.
Mar 19, 00:55 UTC
Update -
Actions is operating normally.
Mar 19, 00:55 UTC
Update -
The provider has reported full mitigation of the underlying issue, and Actions has been healthy since approximately 00:15 UTC.
Mar 19, 00:55 UTC
Update -
We are continuing to investigate issues with delayed or failed workflow runs with Actions. We are engaged with a third-party provider who is also investigating issues and has confirmed we are impacted.
Mar 19, 00:22 UTC
Update -
Some customers may be experiencing delays or failures when queueing workflow runs
Mar 18, 23:45 UTC
Investigating -
We are investigating reports of degraded performance for Actions
Mar 18, 23:45 UTC