Resolved -
On February 21 2025 12:00 UTC - 2/24/2025, 18:31 UTC, the Copilot Metrics API failed to ingest daily metrics aggregations for all customers resulting in failure to populate new metrics from 2025-02-21 to 2025-02-24. This failure was triggered by the metrics ingestion process timing out when querying across the event dataset. The API was functional for retrieving historical metrics prior to 2025-02-21.
On Monday morning 2/24/2025, 15:00 UTC, customer support was notified of the issue and the team deployed a fix to resolve query timeouts and ran backfills for the data from 2025-02-21 to 2025-02-23.
We are working to prevent further outages by adding more alerting to timeouts and have further optimized all our queries to aggregate data.
Feb 24, 18:31 UTC
Update -
We have restored all of the data for 2025-02-21 to 2025-02-23. The data is queryable through the Copilot Metrics API. We are continuing to monitor the metrics data and expect to resolve the incident in the next hour.
Feb 24, 18:25 UTC
Update -
We expect the missing data from the weekend to be available within two hours.
Feb 24, 17:50 UTC
Update -
Copilot-metrics is in the process of restoring the usage statistics for 2025-02-23, we will continue to restore the previous 2 days over the next few hours.
Feb 24, 16:28 UTC
Update -
Customers may not be able to review their usage statistics for copilot starting Saturday through Monday morning UTC. The API is functioning normally, but no data is available for those time periods. We are working on backfilling the data and all metrics will be eventually available later today. We estimate recovery within in the next few hours and will provide updates on this as the recovery process proceeds.
Feb 24, 15:56 UTC
Update -
We are investigating reports of issues with service: Copilot metrics API. We will continue to keep users updated on progress towards mitigation.
Feb 24, 15:19 UTC
Investigating -
We are currently investigating this issue.
Feb 24, 15:17 UTC